Airtel 4G + OS X El Capitan Quick Fix

[Update]: There is absolutely no support from Airtel on this one. Neither their support team nor their technical team is of any help. It’s real sad to see them not even respond to the queries or provide an easier way to upgrade to a newer router. Unfortunately, in the 4G world where they’ve a monopoly you can’t ask for a better service. So,I just upgraded to the Airtel 4G Hotspot(Huawei Mobile Wifi). It costed me Rs. 2300/- but I’m at peace now! Having to interact and follow up with them on everyday basis has been painful. 

Have you found this strange issue with Airtel 4G dongle not connecting to the internet after upgrading to OS X El Capitan? If Yes, here’s a quick fix that you can try. It worked for me, but this is no official. All the changes I mention here are easily revertable, however, I don’t take any responsibility if you land up messing your system. That’s the “Works on my machine” disclaimer.

I’ve got a 4G Dongle from Airtel that is Huawei LTE USB Rotator – E3276 and ever since I upgraded to OS X El Capitan, it failed to connect. It throws up an error message “The device has been disconnected or is unavailable” and couldn’t find the “Network” tab anymore in the fancy Airtel masked client app.

I did approach Airtel for an official support to El Capitan upgrade however with the little knowledge that their technical team has, I don’t expect them to respond anytime sooner. While I visited their office in Bangalore, I pretended to be an inefficient user of mac, but that landed up in they trying to sell me their newest wireless router.

Doing my research

Just like you, I did my part of research on the internet to find some fixes around this problem. Not just searching about Airtel’s 4G dongle or Huawei modem but everything that I could figure out what has changed in El Capitan. While most of them would explain the cause of the issue to be the El Capitan’s requirement of signed kernel extensions and disabling the System Integrity Protection (“csrutil disable“) from the recovery mode will fix this issue. However, all that didn’t work. Even deleting the airtel installation, plugging out the modem, disabling the system integrity protection, restarting and reinstalling the drivers did not help detect the modem. The problem seems to be much internal. So, here’s my version of the fix –

First:

  1. Unplug the Airtel 4G dongle
  2. Delete your Airtel installations from your applications
  3. Go to System Preferences > Network remove services that starts with “Huawei..” if present
  4. Restart your mac

Second:

  1. Connect your modem
  2. On Auto-run, install the software again
  3. Go to System Preferences > Network
    1. Add a new service (use the + sign in the left corner)
    2. Select the interface has “HUAWEIMobile-Modem” – it auto sets the same name. Let it be!
      Airtel-4G-El-Capitan-1
    3. In the next screen, under the Default Configuration add the phone number *99#
      Airtel-4G-El-Capitan-2
    4. Click on Advanced then set the Vendor: Generic, Model: GPRS(GSM/3G), APN: airtelgprs.com  and click Ok.
      Airtel-4G-El-Capitan-2-1
    5. Click Apply and then Connect. Voila! That connects!
      Airtel-4G-El-Capitan-3
  4. Open a browser and see if your internet works!

Known Issues:

Yes, this is a temp fix and you will land up in few issues.

  1. You cannot manually select a network – it auto connects to an available network. Since you bypass the Airtel/Huawei client app, there’s no way you can find/troubleshoot network problems.
  2. If it works then it works! If it doesn’t then restart and redo the same steps.

Icing on the cake

Surprisingly my Airtel client App showed up working when I did the following –

  1. Added the HuaweiMobile (not the HUAWEIMobile-Modem) interface in the Network
  2. Then, clicked on upgrade option – it tried reinitializing the device and detects a connected network. After that, you will magically see the network tab appearing.
  3. Don’t believe me? See this –

Airtel-4G-El-Capitan-Hero

Note: If you disconnect, you can reconnect from this screen without issues. However, if you pull the modem out, you will have to repeat every step again.

Official fix?

In an attempt to sell newer devices and newer plans, I doubt neither Airtel nor Huawei would provide an official fix out. El Capitan has been in beta for a long time and they should have come up with updates by now. If I get to hear from them, I will update them here.

If you have another workaround, I would love to hear them. Add them to the comments!

Thanks!

Advertisements